სხვა:სიჩქარის შეზღუდვა (შეიპერი)

WiKi MikroTik geo გვერდიდან
Jump to navigation Jump to search

Per Connection Queue (PCQ) შეიპერის მრავალსახეობა, რომელიც შეიძლება გამოყენებულ იქნეს იმასათვის, რომ დინამიურად გაათანაბროს ან შეზღუდოს ტრაფიკი მრავალ მომხმარებელზე.

ქსელის სქემა

ქსელის სქემა (სიჩქარის შეზღუდვა (შიპერი) MikroTik-ზე)

სიჩქარის შეზღუდვა და მომხმარებელთა შორის არხის თანაბარი განაწილება

ამოცანა

ყველა მომხმარებელს შევუზღუდოთ ატვირთვის სიჩქარე 5 Mb/s-მდე, და ჩამოტვირთვის სიჩქარე 10 MB/s-მდე. ეს მდგომარეობა გულისხმობს, რომ შეზღუდვა არის საერთო ყველასთვის, და არა თითოეული მომხმარებლისთვის ინდივიდუალურად.

შეიძლება დაგებადოთ კითხვა: რატომ უნდა გავაკეთოთ შეზღუდვა, თუ მივიღებთ უფრო მეტს? მაგალითად, ხელშეკრულების პირობით პროვაიდერთან სიჩქარე 10 MB/s ჩამოტვირთვაზე და ატვირთვაზე, მაგრამ პროვაიდერი უფრო მეტს იძლევა. პასუხი მარტივია. იმისათვის, რომ შევძლოთ დაკონფიგურირება QoS (არხის სიგანის თანაბარი განაჭილება მომხმარებლებს შორის, პრიორიტეტიზაცია IP-ტელეფონიასთვის და ა.შ.) როუტერმა უნდა იცოდეს, რა სისწრაფით უნდა მოხდეს სიჩქარის გამოყოფა. ეს პირობა წარმოადგენს აუცილებლობას. თუ სიჩქარის მაქსიმალურ შეზღუდვას არ მივუთითებთ ან მივუთითოთ სიჩქარე რეალურზე მეტი, მაშინ QoS შეძლებს კორექტულად მუშაობას.

ვარიანტი ერთ ინტერნეტ არხთან

ინტერფეისების იდენტიფიკაციისთვის სიძლება მივუთითოთ მათი სახელი:
/queue simple
add max-limit=5M/10M name="Internet download/upload limit" target=bridge-LAN


ან IP-მისამართი:
/queue simple
add max-limit=5M/10M name="Internet download/upload limit" target=10.1.100.0/24

გავრცელებული შეცდომა

ამ ვარიანტს აქვს გავრცელებული შეცდომა რომელშიც არ უთითებენ პარამეტრის მნიშვნელობას "target" და ამის ნაცვლად იყენებენ პარამეტრის მნიშვნელობას "dst":

/queue simple
add dst=ether1-WAN1 max-limit=5M/10M name="Internet download/upload limit" target=""

როგორც კორექტული არგუმენტი ასეთი პარამეტრების ამბობენ, რომ ყველაფერი მუშაობს. და მართლაც, თუ როგორც მაქსიმალური სიჩქარის მნიშვნელობები იქნება მითითებული მაქსიმალური სიჩქარეები (მაგალითად ასე:max-limit=10M/10M), მაშინ შემოწმებისას გაირკვევა, რომ შეზღუდვა მუშაობს. თუ სიჩქარე ატვირთვაზე და ჩამოტვირთვაზე იქნება განსხვავებული, როგორც ჩვენს მაგალითში (max-limit=5M/10M), შემოწმებისას გაირკვევა, რომ მოცემული მნიშვნელობა ჩამოტვირთვისთვის მუშაბს და ატვირთვისთვის და პირიქით.

ვარიანტი ორი ინტერნეტ არხით

თუ გამოიყენება ორი ინტერნეტ არხი, თქვენ უნდა შეიქმნათ ორი ცალკეული წესები (თითი თითოეული WAN-არხიოსთვის):

/queue simple
add dst=ether1-WAN1 max-limit=5M/10M name="Internet download/upload limit" target=bridge-LAN
add dst=ether2-WAN2 max-limit=8M/16M name="Internet download/upload limit" target=bridge-LAN

თუ არ გამოყოფთ თითოეულ გარე არხზე ცალკე წესს, მაშინ ლიმიტი ვრცელდება ორივე არხზე.. ანუ, შესაძლებელი იქნება ჩამოტვირთოთ არა 10 Mb/s სიჩქარით ერთდროულად ერთიდან და მეორედან 10 Mb/s, არამედ 10-ით ორივედან.რა თქმა უნდა, ეს ეხება სიტუაციას, როდესაც ორივე გარე არხი მუშაობს ერთდროულად. თუ გარე არხები დაკონფიგურირებული სარეზერვო რეჟიმში, მაშინ ინტერნეტ პროვაიდერი გაწვდით სხვადასხვა სიჩქარეს და ასე რომ თქვენ უნდა გააკეთოთ ორი სხვადასხვა არხი, რომ მიუთითოთ სიჩქარის აქტუალური მნიშვნელობა.

მომხმარებელთა შორის არხის სიგანის თანაბარი განაწილება

წინა მაგალითებში, ჩვენ გავმართეთ სიჩქარის შეზღუდვა ზედა ზღვარზე ატვირთვის და ჩამოტვირთვის. მაგრამ ამავე დროს, სიტუაცია შეიძლება წარმოიშვას, რომლის მიხედვითაც ზოგიერთ მომხმარებელს უფრო მეტი სიჩქარე მიეწოდოს ვიდრე სხვას. ამ განყოფილებაში ჩვენ დავაკონფიგურირებთ მომხმარებელთა შორის სიჩქარის თანაბარ განაწილებას, ანუ, 1 მომხმარებელი შეძლებს ჩმოტვირთოს 10 Mbps სიჩქარით, 2 მომხმარებელი - 5 Mbps სიჩქარით, 4 მომხმარებელი - 2,5 Mbps-ით და ასე შემდეგ. ამავე დროს, თუ ერთ მომხმარებელს სჭირდება მხოლოდ 2 Mbps, და ორ მათგანს 20 Mbps, მაშინ პირველი მიიღებს ზუსტად 2 Mbit/s (რადგან ეს უფრო მეტია, ვიდრე 1/3 10 Mbit/s-დან), ხოლო დანარჩენი ორი კი თანაბრად დარჩენილ არხს მიიღებს, ანუ 4 Mbps-ით.

/queue simple
add max-limit=5M/10M name="Internet download/upload limit" queue=pcq-upload-default/pcq-download-default target=10.1.100.0/24

თითოეული მომხმარებლისთვის სიჩქარის ლიმიტი

ამოცანა: თითოეული მომხმარებლისთვის ჩამოტვირთვის სიჩქარის შეზღუდვა 1 Mb/s-ზე, და ჩამოტვირთვის სიჩქარე 2 MB/s-ზე. ანუ, ერთი მომხმარებელი გადმოწერს სიჩქარით 2 MB/s, 2 მომხმარებელი ატვირთავს, თითოეული 2 MB/s სიჩქარით, ანუ, სულ 4 Mb/s, 4 მომხმარებელი ჩამოტვირთავს, თითოეული სიჩქარე 2 Mb / s, ანუ, სულ 8 Mb / s და ასე შემდეგ.

/queue type
add name="pcq-download" kind=pcq pcq-rate=2M pcq-classifier=dst-address
add name="pcq-upload" kind=pcq pcq-rate=1M pcq-classifier=src-address