სხვა:master-port კონფიგურაციის წაშლა

WiKi MikroTik geo გვერდიდან
Jump to navigation Jump to search

master-port-ის წაშლა MikroTik RouterOS-ში 6.41 და ზემოთ

დაწყებული RouterOS 6.41 და ზემოთ პარამეტრებიდან წაშლილია კონფიგურაცია master-port რის შესახებაც იყო გაფრთხილება ოფიციალურ ვებ-გვერდზე:

What's new in 6.41 (2017-Dec-22 11:55):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload). This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" 
option as such. Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions. The rest of RouterOS Switch specific configuration remains untouched in usual menus for now. Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


RouterOS 6.40.5 было:
RouterOS 6.40.5 იყო


RouterOS 6.41 стало:
RouterOS 6.41 გახდა

სქრინშოტებიდან ჩანს, რომ ვერსიაში 6.41 გაქრა ოფცია "Master Port:" და საინფორმაციო ველი "Switch". ახლა ყველა ინფორმაცია, რომელიც გადაეცემა OSI-ის მე-2 დონის მოდულით იქნება გადაცემული Bridge-ინტერფეისის მეშვეობით. swich-ჩიპის გამოყენება (hw-offload) იქნება ავტომატურად აქტივირებული თუ შესაძლებელია. ჩვეულებრივ, ნებისმიერი ინტერფეისის დამატებისას Bridge-ში მას ექნება გააქტიურებული ოფცია "Hardware Offload", რომელიც გადასცემს მე-2 დონის ყველა ინფორმაციას switch-ჩიპის მეშვეობით. თუ ამ ოფციას მოვაშორებთ, ხოლო დამუშავება განხორციელდება ოპერაციული სისტემის ძალებით.

ცვლილებები კონფიგურაციაში განახლებისას RouterOS 6.41-მდე და ძველი

განვიხილოთ რას ნიშნავს ეს ქსელის ადმინისტრატორებისთვის. გადასვლისას RouterOS 6.41-ზე და ზემოთ RouterOS ვერსიიდან 6.40.5 და ქვემოთ ყველა პარამეტრი master-port ავტომატურად იქნება გადატანილი Bridge-ინტერფეისში.


Icon-warn.png

გაფრთხილება: თუ განვახორციელებთ downgrade-ს ვერსიამდე, რომელიც თავსებადია master-port-თან, მაშინ პარამეტრები არ დაუბრუნდება ადგილს. რეკომენდირებულია გააკეთოთ სარეზერვო კოპირება განახლებამდე.


განახლებამდე RouterOS 6.41-მდე:
/interface ethernet
set [ find default-name=ether1 ] name=ether1-WAN1
set [ find default-name=ether5 ] name=ether5-LAN1-master
set [ find default-name=ether2 ] master-port=ether5-LAN1-master name=ether2-LAN1
set [ find default-name=ether3 ] master-port=ether5-LAN1-master name=ether3-LAN1
set [ find default-name=ether4 ] master-port=ether5-LAN1-master name=ether4-LAN1
/ip address
add address=10.10.10.1/24 interface=ether1-WAN1 network=10.10.10.0
add address=192.168.0.1/24 interface=ether5-LAN1-master network=192.168.0.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1


განახლების შემდეგ RouterOS 6.41-ზე და ზემოთ:
/interface bridge
add admin-mac=6C:3B:6B:3B:80:1D auto-mac=no comment="created from master port" name=bridge1 protocol-mode=none
/interface ethernet

set [ find default-name=ether1 ] name=ether1-WAN1
set [ find default-name=ether2 ] name=ether2-LAN1
set [ find default-name=ether3 ] name=ether3-LAN1
set [ find default-name=ether4 ] name=ether4-LAN1
set [ find default-name=ether5 ] name=ether5-LAN1-master
/interface bridge port
add bridge=bridge1 interface=ether2-LAN1
add bridge=bridge1 interface=ether3-LAN1
add bridge=bridge1 interface=ether4-LAN1
add bridge=bridge1 interface=ether5-LAN1-master
/ip neighbor discovery-settings
set discover-interface-list=!dynamic

/ip address
add address=10.10.10.1/24 interface=ether1-WAN1 network=10.10.10.0
add address=192.168.0.1/24 interface=bridge1 network=192.168.0.0
/ip firewall nat
add action=masquerade chain=srcnat out-interface=ether1-WAN1