SwOS/RB250 RB260

WiKi MikroTik geo გვერდიდან
Jump to navigation Jump to search

რეზიუმე

SwOS არის ოპერაციული სისტემა, რომელიც შექმნილია სპეციალურად MikroTik კომუტატორული პროდუქტების ადმინისტრირებისათვის.

SwOS იმართება თქვენი ვებ ბრაუზერიდან. ის გაძლევთ ყველა ძირითად ფუნქციას მართვადი კომუტატორებისათვის, და ასევე სხვა მრავალი: გაძლევთ საშუალებას მართოთ port-to-port forwarding, broadcast storm control, apply MAC filter, configure VLANs, mirror traffic, apply bandwidth limitation და even adjust some MAC და IP header fields.

Icon-warn.png

გაფრთხილება: RouterBOARD კომუტატორების თითოეულ სერიას აქვს თავისი firmware, რომელიც არ შეიძლება დაყენდეს სხვა სერიის მოდელებზე! იმ შემთხვევაში, თუ არასწორი ინსტალაცია შემთხვევით გაკეთდა, სწორი Firmware-თი უნდა შეიცვალოს, გაეცანით ინსტრუქციას "Reinstall SwOS firmware" სექციაში ქვემოთ.

  • RB250GS supports SwOS v1.0 till v1.17.
  • RB260GS supports SwOS v1.7 till v1.17.
  • RB260GSP supports SwOS v1.11 till v1.17.
  • ახალი RB260GS (CSS106-5G-1S), ახალი RB260GSP (CSS106-1G-4P-1S) მხარდაჭერილია SwOS v2.0 და ახალი. იხილეთ CSS106 სერიის სახელმძღვანელო.


RB260 სერიის მახასიათებლები

FeaturesDescription
Forwarding
  • Full non-blocking wirespeed switching
  • Up to 2k MAC entries in Host table
  • Forwarding Database works based on SVL or IVL
  • Port Isolation
  • Port Lock
  • Jumbo frame support - 9198 bytes
Mirroring
  • Port based mirroring
VLAN
  • Fully compatible with IEEE802.1Q
  • Port based VLAN
  • VLAN filtering
Quality of Service (QoS)
  • Ingress traffic limiting (by ACL)
  • Egress traffic limiting
Access Control List
  • Ingress ACL tables
  • Up to 32 ACL rules (limited by RouterOS)
  • Classification based on ports, L2, L3, L4 protocol header fields
  • ACL actions include filtering, forwarding and modifying of the protocol header fields

კომუტატორთან დაკავშირება

გახსენით თქვენი ვებ-ბრაუზერი და შეიყვანეთ თქვენი კომუტატორის IP-მისამართი (ნაგულისხმევი 192.168.88.1) და გამოჩნდება სისტემაში შესვლის ეკრანი.

SwOS ნაგულისხმევი IP მისამართი: 192.168.88.1, მომხმარებილის სახელი: admin ხოლო პაროლი არ გააჩნია.

Icon-note.png

შენიშვნა: MikroTik neighbor discovery Protocol ინსტრუმენტები შეიძლება იქნას გამოყენებული Mikrotik კომუტატორების IP მისამართების აღმოსაჩენად. Manual:IP/Neighbor_discovery. ამჟამად LLDP არ არის მხარდაჭერილი.


ინტერფეისის მიმოხილვა

SwOS ინტერფეისის მენიუ შედგება რამდენიმე ჩანართისგან: Link, SFP, Forwarding, Statistics, VLAN, VLANs, Static Hosts, Hosts, SNMP, ACL და System.

ღილაკების აღწერა SwOS კონფიგურაციის ინსტრუმენტში:

  • Append - ახალი ელემენტის დამატება სიის ბოლოში
  • Apply All - კონფიგურაციის მიმდინარე ცვლილებების მისადაგება
  • Cut - სიიდან ელემენტის წაშლა
  • Clear - ელემენტის თვისებების რესეტი
  • Discard Changes - შეუნახავი კონფიგურაციის წაშლა
  • Insert - ახალი ელემენტის დამატება სიაში (განათავსებს მას არსებული პუნქტის წინ)
  • Sort - VLAN ცხლის დალაგება VLAN-ID-ის მიხედვით


  • Change Password - კომუტატორზე პაროლის შეცვლა
  • Logout - მიმდინარე კომუტატორიდან გამოსვლა
  • Reboot - გადატვირთეთ კომუტატორი
  • Reset Configuration - ქარხნული პარამეტრების აღდგენა
  • Choose File - აირჩიეთ განახლების ან სარეზერვო კოპირების ფაილი
  • Upgrade - კომუტატორის firmware-ს განახლება
  • Restore Backup - კომუტატორის კონფიგურაციის აღდგენა, არჩეული სარეზერვო ფაილის გამოყენებით
  • Save Backup - კომუტატორიდან სარეზერვო კოპიის ფაილის შექმნა და ჩამოტვირთვა

სისტემის ჩანართი

სისტემის ჩანართი ასრულებს შემდეგ ფუნქციებს:

  • ზოგადი ინფორმაცია კომუტატორის შესახებ
  • კომუტატორის მართვა
  • საწყისი პარამ,ეტრების აღდგენა
  • სარეზერვო კოპირება და კონფიგურაციის აღდგენა
  • Firmware-ს განახლება


Icon-note.png

შენიშვნა: SwOS იყენებს მარტივ ალგორითმს, რათა უზრუნველყოს კავშირი TCP/IP პროტოკოლით - ის მხოლოდ პასუხობს იმავე პაკეტის IP და MAC მისამართს, რომლიდანაც მოვიდა. ამასთანავე არ არსებობს საჭიროება Default Gateway თვად მოწყობილობაში.


Property Description
IP Addressკომუტატორის IP მისამართი
Identityკომუტატორის სახელი (Mikrotik neighbor discovery პროტოკოლისთვის)
Allow FromIP მისამართი, საიდანაც სერვისი ხელმისაწვდომია. ნაგულისხმევი მნიშვნელობა არის '0.0.0.0/0' - ნებისმიერი მისამართი
Allow From Portsკომუტატორის პორტების ჩამონათვალი, საიდანაც სერვისი ხელმისაწვდომია
Allow From VLANVLAN ID, საიდანაც სერვისის ხელმისაწვდომობა (VLAN Mode on ingress port must be other than disabled in order to connect)
Watchdogსისტემის მონიტორინგის ჩართვა ან გამორთვა. იგი დაარესეტებს CPU-ს გადამრთველს შეცდომის შემთხვევაში
Mikrotik Discovery Protocolჩართვა ან გამორთვა Mikrotik neighbor discovery protocol
MAC Addressკომუტატორის MAC მისამართი (მხოლოდ წაკითხვა)
Serial Numberკომუტატორის სერიული ნომერი (მხოლოდ წაკითხვა)
Versionკომუტატორის Firmware ვერსია (მხოლოდ წაკითხვა)
Uptimeკომუტატორის მუშაობის მიმდინარე დრო (მხოლოდ წაკითხვა)

პაროლი, სარეზერვო კოპირება და Firmware განახლება

ფაილი:Swos system2.png
System management settings

შესაძლებელია Firmware upgraded/downgraded firmware ფაილის სერჩევით და დაჭერით განახლება ღილაკს. კომუტატორი გადაიტვირთება ავტომატურად წარმატებული განახლების შემდეგ.

PoE და Health (RB260GSP მხოლოდ)


ფაილი:Swos system3.png
RB260GSP PoE and Health settings


Property Description
Port1 PoE In Long Cableთუ ჩართულია, ის გამორთავს მოკლე ჩართვის აღმოჩენას ყველა გამსვლელ PoE პორტებზე, რაც საშუალებას მოგვცემს გამოვიყენოთ გრძელი ethernet კაბელები. ეს პოტენციურად სახიფათო პარამეტრია, და მისი გამოყენება მოითხოვს სიფრთხილეს.
Voltageგვიჩვენებს შემომსვლელ დატვირთვას, შემოწმებული ვოლტებში
Temperatureაჩვენებს PCB (დაფის, პლატის) ტემპერატურას, გრადუსი ცელსიუსით

Link Tab

Link Tab საშუალებას გაძლევთ::

  • Ethernet პორტების კონფიგურაცია
  • Ethernet პორტების მონიტორინგის სტატუსი


Property Description
Enabledპორტის ჩართვა ან გამორთვა
Link Statusმიმდინარე ბმულის სტატუსი (მხოლოდ წაკითხვა)
Auto Negotiationauto negotiation ჩართვა ან გამორთვა
Speedმიუთითეთ პორტის სიჩქარის პარამეტრები (აუცილებელია auto negotiation გამორთვა)
Full Duplexმიუთითეთ პორტის დუპლექსის რეჟიმი (აუცილებელია auto negotiation გამორთვა)
Flow control 802.3x Flow control ჩართვა ან გამორთვა

PoE (RB260GSP მხოლოდ)

PoE პარამეტრების კონფიგურაცია გამართავს გამომავალ Power over Ethernet-ს RB260GSP port2-port5-ზე და აჩვენებს PoE სტატუსს და გაზომვებს.


Property Description
PoE Out

PoE out რეჟიმის მისადაგება პორტისთვის:

  • off - ყველა გამოვლენა და PoE out გამორთულია
  • auto - გამოვლენა კეთდება წინაღობასთან მიმართებაში სათადარიგო წყვილსე, რომ შემოწმდეს, აქვს თუ არა პორტს PoE შესაძლებლობა. პორტის ჩასართავად შემოწმებული მნიშვნელობა უნდა იყოს 3kΩ-დან 26.5kΩ-დე დიაპაზონში
  • on - PoE out ჩართულია მიუხედავად პორტის წინაღობისა. გამოიყენეთ ეს ფრთხილად, რადგან მან შეიძლება მიერთებული მოწყობილობა დააზიანოს
  • calibr - მექანიკური პორტის PoE out გადაწყობა. ეს შეიძლება იყოს აუცილებელი, თუ არის პრობლემა მიერთებული მოწყობილობის კვებასთან.
PoE Priorityპორტის პრიორიტეტი PoE კვებისთვის. თუ ინსტალაცია მიმდინარეობს კვების ხარვეზებით, პორტი ყველაზე დაბალი პრიორიტეტით გაითიშება პირველი. 1 - პორტი ყველაზე მაღალი პრიორიტეტით; 4 - პორტი ყველაზე დაბალი პრიორიტეტით
PoE Status

მიმდინარე PoE გამომსვლელი პორტის სტატუსი (მხოლოდ-წაკითხვა):

  • disabled - PoE გამომსვლელი გამორთულია
  • waiting for load - "ავტო" რეჟიმი გამოავლენს წინაღობას დიაპაზონის გარეთ PoE გამომსვლელის ჩართვისთვის
  • powered on - PoE გამომსვლელი ჩართულია
  • short circuit - თუ გამოვლენილია, PoE გამომსვლელი გამორთულია, რომ უზრუნველჰყოს, რომ არ არის დამატებითი დაზიანება მოწყობილობაზე კვებით და არვ არის დაზიანებული მოწყობილობაზე კვება
  • voltage too low - არ მიეწოდება საკმარისი ძაბვა მოწყობილობის ჩასართავად PoE გამომსვლელ პორტზე
  • current too low - არ არის საკმარისი ძაბვა მოწყობილობის ჩასართავად PoE გამომსვლელ პორტზე
  • waiting for cable disconnect - მექანიკური განმეორებითი კალიბრაციისთვის გამოიყენეთ "calibr" მან იპოვა მიერთებული მოწყობილობა და ელოდება გამორთვას კალიბრაციის პროცესის დასრულებისათვის
PoE Currentაჩვენებს ამჟამინდელ მოხმარებას პორტებზე მილიამპერებში
PoE Powerაჩვენებს PoE გამომსვლელი პორტის სიმძლავრეს, ვატებში

SFP Tab

SFP Tab საშუალებას გაძლევთ:

  • SFP პორტების კონფიგურაცია
  • SFP პორტების მონიტორინგის სტატუსი


Property Description
EnabledSFP პორტის ჩართვა ან გამორთვა
Auto NegotiationSFP პორტის auto negotiation ჩართვა ან გამორთვა (ზოგიერთმა SFP მოდულმა შესაძლოა მოითხოვოს მისი გამორთვა მუშაობისთვის)
Icon-note.png

შენიშვნა: SFP+ 1m/3m DAC კაბელის გამოყენება ან S-RJ01 მოდულის, მოწყობილობა ყოველთვის აჩვენებს, რომ კავშირი დამყარდა, იმ შემთხვევაშიც კი, თუ მეორე მხარეს სხვა არაფერია დაკავშირებული.


Forwarding Tab

Forwarding Tab provides advanced forwarding options among switch ports, port locking, port mirroring, bandwidth limit and broadcast storm control features.

On RB260 series switches ingress rate per port as well as rate for broadcast traffic can be configured with Access Control List by setting Rate. ACL must have one port per entry to provide bandwidth limiting properly.


Property Description
ForwardingForwarding table - allows or restricts traffic flow between specific ports
Port Lock
  • Port Lock - Enable or disable MAC address learning on this port
  • Lock On First - Enable or disable MAC address learning on this port (MAC address from the first recieved packet will still be learnt)
Port Mirroring
  • Mirror Ingress - Whether traffic entering this port must be copied and forwarded to mirroring target port
  • Mirror Egress - Whether traffic leaving this port must be copied and forwarded to mirroring target port
  • Mirror To - Mirroring target port
Bandwidth Limit
  • Ingress Rate - Limit traffic entering this port (bps) (only supported on RB250GS)
  • Egress Rate - Limit traffic leaving this port (bps)
Broadcast Storm Control
  • Storm Rate - Limit the number of broadcast packets transmitted by an interface (only supported on RB250GS)
  • Include Unicast - Include unicast packets without an entry in host table in Storm Rate limitation (only supported on RB250GS)

Statistics Tab

Provides detailed information about received and transmitted packets.

Packet Flow

Packet processing in SwOS is described here: Atheros8316 packet flow diagram

VLAN Tab

VLAN configuration for switch ports.

Property Description
VLAN Mode

VLAN mode for ingress port:

  • disabled - VLAN table is not used. Switch ignores VLAN tag part of tagged packets
  • optional - Handle packets with VLAN tag ID that is not present in VLAN table just like packets without VLAN tag
  • enabled - Drop packets with VLAN tag ID that is not present in VLAN table. Packets without VLAN tag are treat as tagged packets with Default VLAN ID
  • strict - Same as enable, but also checks VLAN support for inbound interface (drop packets with VLAN tag ID and ingress port that are not present in VLAN table)
VLAN ReceiveDefines the type of allowed packets on ingress port: any / only tagged / only untagged (only supported on RB260GS)
Default VLAN IDSwitch will treat both untagged and "Default VLAN ID" tagged ingress packets as they are tagged with this VLAN ID. It is also used to untag egress traffic if packet's VLAN ID matches "Default VLAN ID". The VLAN tag itself will only be added if there is VLAN Header = add if missing specified on egress port
Force VLAN IDWhether to apply Default VLAN ID to incoming packets with VLAN tag
VLAN Header
  • leave as is - if VLAN header is present it remains unchanged
  • always strip - if VLAN header is present it is removed from the packet
  • add if missing - if VLAN header is not present it is added to the packet (VLAN ID will be Default VLAN ID of ingress port)
Icon-note.png

Note: VLAN modes enabled and strict require VLAN ID 1 in VLANs table to allow access of untagged traffic to switch itself.


Example

VLANs Tab

VLAN tables specifies certain forwarding rules for packets that have specific 802.1q tag. Basically the table contains entries that map specific VLAN tag IDs to a group of one or more ports. Packets with VLAN tags leave switch through one or more ports that are set in corresponding table entry. VLAN table works together with destination MAC lookup to determine egress ports. VLAN table supports up to 4096 entries.

RB250GS VLANs tab

Property Description
VLAN IDVLAN ID of the packet
PortsPorts the packet should be mapped to

RB260GS VLANs tab

Property Description
VLAN IDVLAN ID of the packet
PortsEach port has individual VLAN header options for each VLAN ID. Depending on VLAN mode if lookup is done in this table, egress action of packets is processed by this option. Egress option from VLAN tab is ignored.

Hosts Tab

This table represents dynamically learnt MAC address to port mapping entries. When switch receives a packet from certain port, it adds the packets source MAC address X and port it received the packet from to host table, so when a packet comes in with destination MAC address X it knows to which port it should forward the packet. If the destination MAC address is not present in host table then it forwards the packet to all ports in the group. Dynamic entries take about 5 minutes to time out.

Icon-note.png

Note: RB250G and RB260G series switches support 2048 host table entries.


Property Description
PortsPorts the packet should be forwarded to (read-only)
MACLearned MAC address (read-only)
VLAN IDLearned VLAN ID (read-only) (only supported on RB260GS/RB260GSP)

Static Hosts Tab

Static host table entries. Static entries will take over dynamic if dynamic entry with same mac-address already exists. Also by adding a static entry you get access to some more functionality.


Property Description
PortsPorts the packet should be forwarded to
MACMAC address
VLAN IDVLAN ID (only supported on RB260GS/RB260GSP)
DropPacket with certain MAC address coming from certain ports can be dropped
MirrorPacket can be cloned and sent to mirror-target port

ACL Tab

An access control list (ACL) rule table is very powerful tool allowing wire speed packet filtering, forwarding and VLAN tagging based on L2,L3 protocol header field conditions. SwOS allow you to implement limited number of access control list rules (32 simple rules (only L2 conditions are used); 16 rules where both L2 and L3 conditions are used; or 8 advanced rules where all L2,L3 and L4 conditions are used). Each rule contains a conditions part and an action part.


Conditions part parameters

Property Description
FromPort that packet came in from
MAC SrcSource MAC address and mask
MAC DstDestination MAC address and mask
EthertypeProtocol encapsulated in the payload of an Ethernet Frame
VLAN

VLAN header presence:

  • any
  • present
  • not present
VLAN IDVLAN tag ID
PriorityPriority in VLAN tag
IP Src (IP/netmask:port)Source IPv4 address, netmask and L4 port number
IP Dst (IP/netmask:port)Destination IPv4 address, netmask and L4 port number
ProtocolIP protocol
DSCPIP DSCP field

Action part parameters

Property Description
Redirect ToWhether to force new destination ports. If Redirect To is enabled and no ports specified in Redirect To Ports, packet will be dropped
Redirect To PortsDestination ports
MirrorClones packet and sends it to mirror-target port
RateLimits bandwidth (bps) (only supported on RB260GS/RB260GSP)
Set VLAN IDChanges the VLAN tag ID, if VLAN tag is present
PriorityChanges the VLAN tag priority bits, if VLAN tag is present


SNMP Tab

SNMP Tab consists of settings to monitor the switch remotely.

Available SNMP data:

  • System information
  • System uptime
  • Port status
  • Interface statistics


Property Description
EnabledEnable or disable SNMP service
CommunitySNMP community name
Contact InfoContact information for the NMS
LocationLocation information for the NMS

Reset

SwOS v1.x - RB260GS and RB260GSP

There are two ways to reset the device to defaults:

Reset button

The only button on the SwOS device. It has two functions:

  • Hold this button during boot time until LED light starts flashing, release the button to reset SwOS configuration (same result as with reset hole)
  • Hold this button during boot time longer, until LED starts to blink twice as fast, and then release it to make the device wait for TFTP firmware upgrade

Jumper reset hole

Located on the bottom of case, behind one of the rubber feet of device – resets SwOS software to defaults. Must short circuit the metallic sides of the hole (with a screwdriver, for example) and boot the device. Hold screwdriver in place until SwOS configuration is cleared.

Reinstall SwOS firmware

It is possible to upload and install SwOS firmware using BOOTP. This example shows how to reinstall SwOS using RouterOS.

Icon-warn.png

Warning: Each RouterBOARD switch series have their own firmware which cannot be installed on other series models! In case wrong installation is accidentally done, correct firmware has to be reinstalled following these instructions.

  • RB250GS supports SwOS v1.0 till v1.17.
  • RB260GS supports SwOS v1.7 till v1.17.
  • RB260GSP supports SwOS v1.11 till v1.17.


  • Configure IP address and DHCP server with BOOTP enabled on the installation router.
/ip address
add address=10.0.0.1/24 interface=ether1
/ip pool
add name=dhcp_pool1 ranges=10.0.0.2-10.0.0.254
/ip dhcp-server
add interface=ether1 address-pool=dhcp_pool1 bootp-support=dynamic disabled=no
/ip dhcp-server network
add address=10.0.0.0/24 gateway=10.0.0.1
  • Upload new SwOS firmware file to the router filesystem.
[admin@MikroTik] /file> print 
 # NAME                     TYPE           SIZE                 CREATION-TIME       
 0 swos-rb260-1.14.lzb     .lzb file        38142              sep/02/2014 08:40:17
  • Configure TFTP server.
/ip tftp
add ip-addresses=10.0.0.0/24 real-filename=swos-rb260-1.14.lzb read-only=yes allow=yes
  • Hold the RESET button of the switch when starting it.
  • After few seconds ACT LED will start blinking. Wait till ACT LED blinks twice as fast and release RESET button.
  • Make ethernet connection between the switch Port1 and ethernet port you configured DHCP server on. After few seconds new firmware should be successfully uploaded and installed.


მოძიებულია „https://mikrotik.config.ge/index.php?title=SwOS/RB250_RB260&oldid=72“-დან